const regex = /\[(?=pid)([^\s]*)[^\]]*\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?=pid)([^\\s]*)[^\\]]*\\]', 'gm')
const str = `Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client "192.168.50.30"
Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client "192.168.50.34"`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);