using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?=pid)([^\s]*)[^\]]*\]";
string substitution = @"\1";
string input = @"Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client ""192.168.50.30""
Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client ""192.168.50.34""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}