#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\S*)(\d.\d.\d)\.(0)(\S*)"
Local $sString = "1.0.0" & @CRLF & _
"1.0.0.0" & @CRLF & _
"1.1.2.0-tag" & @CRLF & _
"1.0.0.1" & @CRLF & _
"1.1.2.1-tag" & @CRLF & _
"1.0.2-tag" & @CRLF & _
"1.0" & @CRLF & _
"1.0-tag" & @CRLF & _
"1.1-tag" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"MyPackage.1.0.0" & @CRLF & _
"MyPackage.1.0.0.2" & @CRLF & _
"MyPackage.1.0.0.0" & @CRLF & _
"MyPackage.1.0.0.0.nupkg" & @CRLF & _
"MyPackage.1.0.0.4.nupkg" & @CRLF & _
"MyPackage.1.0.0.0-mytag" & @CRLF & _
"MyPackage.1.0.0.0-mytag.nupkg" & @CRLF & _
"MyPackage.1.0.0.1-mytag.nupkg" & @CRLF & _
""
Local $sSubst = "${1}${2}${4}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)