import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S*)(\\d.\\d.\\d)\\.(0)(\\S*)";
final String string = "1.0.0\n"
+ "1.0.0.0\n"
+ "1.1.2.0-tag\n"
+ "1.0.0.1\n"
+ "1.1.2.1-tag\n"
+ "1.0.2-tag\n"
+ "1.0\n"
+ "1.0-tag\n"
+ "1.1-tag\n\n\n"
+ "MyPackage.1.0.0\n"
+ "MyPackage.1.0.0.2\n"
+ "MyPackage.1.0.0.0\n"
+ "MyPackage.1.0.0.0.nupkg\n"
+ "MyPackage.1.0.0.4.nupkg\n"
+ "MyPackage.1.0.0.0-mytag\n"
+ "MyPackage.1.0.0.0-mytag.nupkg\n"
+ "MyPackage.1.0.0.1-mytag.nupkg\n";
final String subst = "${1}${2}${4}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}