import re
regex = re.compile(r"(\S*)(\d.\d.\d)\.(0)(\S*)")
test_str = ("1.0.0\n"
"1.0.0.0\n"
"1.1.2.0-tag\n"
"1.0.0.1\n"
"1.1.2.1-tag\n"
"1.0.2-tag\n"
"1.0\n"
"1.0-tag\n"
"1.1-tag\n\n\n"
"MyPackage.1.0.0\n"
"MyPackage.1.0.0.2\n"
"MyPackage.1.0.0.0\n"
"MyPackage.1.0.0.0.nupkg\n"
"MyPackage.1.0.0.4.nupkg\n"
"MyPackage.1.0.0.0-mytag\n"
"MyPackage.1.0.0.0-mytag.nupkg\n"
"MyPackage.1.0.0.1-mytag.nupkg\n")
subst = "${1}${2}${4}"
result = regex.sub(subst, test_str)
if result:
print(result)