use strict;
my $str = '1.0.0
1.0.0.0
1.1.2.0-tag
1.0.0.1
1.1.2.1-tag
1.0.2-tag
1.0
1.0-tag
1.1-tag
MyPackage.1.0.0
MyPackage.1.0.0.2
MyPackage.1.0.0.0
MyPackage.1.0.0.0.nupkg
MyPackage.1.0.0.4.nupkg
MyPackage.1.0.0.0-mytag
MyPackage.1.0.0.0-mytag.nupkg
MyPackage.1.0.0.1-mytag.nupkg
';
my $regex = qr/(\S*)(\d.\d.\d)\.(0)(\S*)/p;
my $subst = '${1}${2}${4}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";