// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S*)(\d.\d.\d)\.(0)(\S*)").unwrap();
let string = "1.0.0
1.0.0.0
1.1.2.0-tag
1.0.0.1
1.1.2.1-tag
1.0.2-tag
1.0
1.0-tag
1.1-tag
MyPackage.1.0.0
MyPackage.1.0.0.2
MyPackage.1.0.0.0
MyPackage.1.0.0.0.nupkg
MyPackage.1.0.0.4.nupkg
MyPackage.1.0.0.0-mytag
MyPackage.1.0.0.0-mytag.nupkg
MyPackage.1.0.0.1-mytag.nupkg
";
let substitution = "${1}${2}${4}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}