#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[[Hh]([^\]]*)\]"
Local $sString = "[H]" & @CRLF & _
"[Hm]" & @CRLF & _
"[Hm7]" & @CRLF & _
"[h]" & @CRLF & _
"[h7]"
Local $sSubst = "[B$1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)