import re
regex = re.compile(r"\[[Hh]([^\]]*)\]")
test_str = ("[H]\n"
"[Hm]\n"
"[Hm7]\n"
"[h]\n"
"[h7]")
subst = "[B$1]"
result = regex.sub(subst, test_str)
if result:
print(result)