const regex = /\[[Hh]([^\]]*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[Hh]([^\\]]*)\\]', 'g')
const str = `[H]
[Hm]
[Hm7]
[h]
[h7]`;
const subst = `[B$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);