using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[Hh]([^\]]*)\]";
string substitution = @"[B$1]";
string input = @"[H]
[Hm]
[Hm7]
[h]
[h7]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}