import Foundation
let pattern = #"\[[Hh]([^\]]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[H]
[Hm]
[Hm7]
[h]
[h7]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[B$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)