// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[[Hh]([^\]]*)\]").unwrap();
let string = "[H]
[Hm]
[Hm7]
[h]
[h7]";
let substitution = "[B$1]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}