package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[Hh]([^\]]*)\]`)
var str = `[H]
[Hm]
[Hm7]
[h]
[h7]`
var substitution = "[B$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}