using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G(?!^)|\""body\""\s*:\s*\"")([^\"",\\]*(?:\\.[^\"",\\]*)*),";
string substitution = @"$1$2";
string input = @"{
""url"": ""RETURNED URL"",
""repository_url"": ""RETURNED URL"",
""labels_url"": ""RETURNED URL"",
""comments_url"": ""RETURNED URL"",
""events_url"": ""RETURNED URL"",
""html_url"": ""RETURNED URL"",
""id"": ""RETURNED_ID"",
""node_id"": ""RETURNED id"",
""number"": 10,
...
""author_association"": ""xxxx"",
""active_lock_reason"": null,
""body"": ""text \""text\"" text, text text, text \\\""text text\"", text, text text"",
""performed_via_github_app"": null
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}