import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\G(?!^)|\\\"body\\\"\\s*:\\s*\\\")([^\\\",\\\\]*(?:\\\\.[^\\\",\\\\]*)*),";
final String string = "{\n"
+ " \"url\": \"RETURNED URL\",\n"
+ " \"repository_url\": \"RETURNED URL\",\n"
+ " \"labels_url\": \"RETURNED URL\",\n"
+ " \"comments_url\": \"RETURNED URL\",\n"
+ " \"events_url\": \"RETURNED URL\",\n"
+ " \"html_url\": \"RETURNED URL\",\n"
+ " \"id\": \"RETURNED_ID\",\n"
+ " \"node_id\": \"RETURNED id\",\n"
+ " \"number\": 10,\n"
+ " ...\n"
+ " \"author_association\": \"xxxx\",\n"
+ " \"active_lock_reason\": null,\n"
+ " \"body\": \"text \\\"text\\\" text, text text, text \\\\\\\"text text\\\", text, text text\",\n"
+ " \"performed_via_github_app\": null\n"
+ "}";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}