# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\G(?!^)|\"body\"\s*:\s*\")([^\",\\]*(?:\\.[^\",\\]*)*),"
test_str = ("{\n"
" \"url\": \"RETURNED URL\",\n"
" \"repository_url\": \"RETURNED URL\",\n"
" \"labels_url\": \"RETURNED URL\",\n"
" \"comments_url\": \"RETURNED URL\",\n"
" \"events_url\": \"RETURNED URL\",\n"
" \"html_url\": \"RETURNED URL\",\n"
" \"id\": \"RETURNED_ID\",\n"
" \"node_id\": \"RETURNED id\",\n"
" \"number\": 10,\n"
" ...\n"
" \"author_association\": \"xxxx\",\n"
" \"active_lock_reason\": null,\n"
" \"body\": \"text \\\"text\\\" text, text text, text \\\\\\\"text text\\\", text, text text\",\n"
" \"performed_via_github_app\": null\n"
"}")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.