const regex = new RegExp('(\\G(?!^)|\\"body\\"\\s*:\\s*\\")([^\\",\\\\]*(?:\\\\.[^\\",\\\\]*)*),', 'gm')
const str = `{
"url": "RETURNED URL",
"repository_url": "RETURNED URL",
"labels_url": "RETURNED URL",
"comments_url": "RETURNED URL",
"events_url": "RETURNED URL",
"html_url": "RETURNED URL",
"id": "RETURNED_ID",
"node_id": "RETURNED id",
"number": 10,
...
"author_association": "xxxx",
"active_lock_reason": null,
"body": "text \\"text\\" text, text text, text \\\\\\"text text\\", text, text text",
"performed_via_github_app": null
}`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);