re = /(\G(?!^)|\"body\"\s*:\s*\")([^\",\\]*(?:\\.[^\",\\]*)*),/m
str = '{
"url": "RETURNED URL",
"repository_url": "RETURNED URL",
"labels_url": "RETURNED URL",
"comments_url": "RETURNED URL",
"events_url": "RETURNED URL",
"html_url": "RETURNED URL",
"id": "RETURNED_ID",
"node_id": "RETURNED id",
"number": 10,
...
"author_association": "xxxx",
"active_lock_reason": null,
"body": "text \\"text\\" text, text text, text \\\\\\"text text\\", text, text text",
"performed_via_github_app": null
}'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result