package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w+?\W){4}(.+)`)
var str = `The wild dogs cry out in the night
As they grow restless, longing for some solitary company
I know that I must do what's right
As sure as Kilimanjaro rises like Olympus above the Serengeti
I seek to cure what's deep inside, frightened of this thing that I've become`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}