use strict;
my $str = 'The wild dogs cry out in the night
As they grow restless, longing for some solitary company
I know that I must do what\'s right
As sure as Kilimanjaro rises like Olympus above the Serengeti
I seek to cure what\'s deep inside, frightened of this thing that I\'ve become';
my $regex = qr/^(?:\w+?\W){4}(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}