import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\w+?\\W){4}(.+)";
final String string = "The wild dogs cry out in the night\n"
+ "As they grow restless, longing for some solitary company\n"
+ "I know that I must do what's right\n"
+ "As sure as Kilimanjaro rises like Olympus above the Serengeti\n"
+ "I seek to cure what's deep inside, frightened of this thing that I've become";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}