import re
regex = re.compile(r"^(?:\w+?\W){4}(.+)", flags=re.MULTILINE)
test_str = ("The wild dogs cry out in the night\n"
"As they grow restless, longing for some solitary company\n"
"I know that I must do what's right\n"
"As sure as Kilimanjaro rises like Olympus above the Serengeti\n"
"I seek to cure what's deep inside, frightened of this thing that I've become")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")