#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),[5-9]\d+$"
Local $sString = "38499,2" & @CRLF & _
"38501,3" & @CRLF & _
"38502,5" & @CRLF & _
"38504,4" & @CRLF & _
"38505,4" & @CRLF & _
"38506,256" & @CRLF & _
"38508,1" & @CRLF & _
"38509,91" & @CRLF & _
"38510,4123" & @CRLF & _
"38511,5123" & @CRLF & _
"38512,5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")