const regex = /,[5-9]\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',[5-9]\\d+$', 'gm')
const str = `38499,2
38501,3
38502,5
38504,4
38505,4
38506,256
38508,1
38509,91
38510,4123
38511,5123
38512,5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}