package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),[5-9]\d+$`)
var str = `38499,2
38501,3
38502,5
38504,4
38505,4
38506,256
38508,1
38509,91
38510,4123
38511,5123
38512,5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}