import re
regex = re.compile(r",[5-9]\d+$", flags=re.MULTILINE)
test_str = ("38499,2\n"
"38501,3\n"
"38502,5\n"
"38504,4\n"
"38505,4\n"
"38506,256\n"
"38508,1\n"
"38509,91\n"
"38510,4123\n"
"38511,5123\n"
"38512,5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")