// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),[5-9]\d+$").unwrap();
let string = "38499,2
38501,3
38502,5
38504,4
38505,4
38506,256
38508,1
38509,91
38510,4123
38511,5123
38512,5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}