re = /,[5-9]\d+$/m
str = '38499,2
38501,3
38502,5
38504,4
38505,4
38506,256
38508,1
38509,91
38510,4123
38511,5123
38512,5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end