#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*"
Local $sString = "static abc_p ABC_P[] = {" & @CRLF & _
"" & @CRLF & _
" /* Netz I */" & @CRLF & _
" {" & @CRLF & _
" N1 " & @CRLF & _
" N1 " & @CRLF & _
" N1 " & @CRLF & _
" 0, " & @CRLF & _
" {" & @CRLF & _
" Flg1" & @CRLF & _
" 0," & @CRLF & _
" Flg2" & @CRLF & _
" 0," & @CRLF & _
" Flg3" & @CRLF & _
" 0," & @CRLF & _
" Flg4" & @CRLF & _
" 0," & @CRLF & _
" }," & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" /* Netz E1 */" & @CRLF & _
" {" & @CRLF & _
" N2 " & @CRLF & _
" N2 " & @CRLF & _
" N2 " & @CRLF & _
" 0, " & @CRLF & _
" {" & @CRLF & _
" Flg1" & @CRLF & _
" 0," & @CRLF & _
" Flg2" & @CRLF & _
" 0," & @CRLF & _
" Flg3" & @CRLF & _
" 0," & @CRLF & _
" Flg4" & @CRLF & _
" 0," & @CRLF & _
" }," & @CRLF & _
" }," & @CRLF & _
"};" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")