$re = '/static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*/m';
$str = 'static abc_p ABC_P[] = {
/* Netz I */
{
N1
N1
N1
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
/* Netz E1 */
{
N2
N2
N2
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
};
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);