import re
regex = re.compile(r"static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*", flags=re.MULTILINE)
test_str = ("static abc_p ABC_P[] = {\n\n"
" /* Netz I */\n"
" {\n"
" N1 \n"
" N1 \n"
" N1 \n"
" 0, \n"
" {\n"
" Flg1\n"
" 0,\n"
" Flg2\n"
" 0,\n"
" Flg3\n"
" 0,\n"
" Flg4\n"
" 0,\n"
" },\n"
" },\n\n"
" /* Netz E1 */\n"
" {\n"
" N2 \n"
" N2 \n"
" N2 \n"
" 0, \n"
" {\n"
" Flg1\n"
" 0,\n"
" Flg2\n"
" 0,\n"
" Flg3\n"
" 0,\n"
" Flg4\n"
" 0,\n"
" },\n"
" },\n"
"};\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")