import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "static\\s+abc_p\\s+ABC_P\\[\\s*\\]\\s*=\\s*\\{(\\n((?:[^\\{]*\\{\\n([^\\}]*)\\}\\,\\n\\s*\\}\\,\\n)))[^;]*";
final String string = "static abc_p ABC_P[] = {\n\n"
+ " /* Netz I */\n"
+ " {\n"
+ " N1 \n"
+ " N1 \n"
+ " N1 \n"
+ " 0, \n"
+ " {\n"
+ " Flg1\n"
+ " 0,\n"
+ " Flg2\n"
+ " 0,\n"
+ " Flg3\n"
+ " 0,\n"
+ " Flg4\n"
+ " 0,\n"
+ " },\n"
+ " },\n\n"
+ " /* Netz E1 */\n"
+ " {\n"
+ " N2 \n"
+ " N2 \n"
+ " N2 \n"
+ " 0, \n"
+ " {\n"
+ " Flg1\n"
+ " 0,\n"
+ " Flg2\n"
+ " 0,\n"
+ " Flg3\n"
+ " 0,\n"
+ " Flg4\n"
+ " 0,\n"
+ " },\n"
+ " },\n"
+ "};\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}