# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})\/(\d{2})\/(.*)\.html/$1/gm;t' <<< "article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html"