package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})/(\d{2})/(.*)\.html`)
var str = `article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}