using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})/(\d{2})/(.*)\.html";
string substitution = @"$1";
string input = @"article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}