#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{4})/(\d{2})/(.*)\.html"
Local $sString = "article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)