re = /(\d{4})\/(\d{2})\/(.*)\.html/m
str = 'article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result