import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in";
final String string = " \"ABHAY KUMAR\" <abhay.kumar@eil.co.in>, \"JATINDER S DUGGAL\" <js.duggal@eil.co.in>, \"MAHESH EASWARAN\" <mahesh.easwaran@eil.co.in>, \"MAHESH GUPTA\" <mahesh.gupta@eil.co.in>, \"MUKESH KUMAR\" <mukesh.kumar@eil.co.in>, \"anand yadav\" <anand.yadav@eil.co.in>, \"SANJIT KUMAR KESHRI\" <sanjit.keshri@eil.co.in>, \"PINTU LAL\" <pintu.lal@eil.co.in>, \"SUSHANT CHANDRA SAXENA\" <sushant.saxena@eil.co.in>, \"VIKAS VIKAS\" <vikask@eil.co.in>, \"PRINCE PRINCE\" <prince.gupta@eil.co.in>\n"
+ "Cc: \"NALIN KUMAR\" <kumar.nalin@eil.co.in>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}