import re
regex = re.compile(r"[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in", flags=re.MULTILINE)
test_str = (" \"ABHAY KUMAR\" <abhay.kumar@eil.co.in>, \"JATINDER S DUGGAL\" <js.duggal@eil.co.in>, \"MAHESH EASWARAN\" <mahesh.easwaran@eil.co.in>, \"MAHESH GUPTA\" <mahesh.gupta@eil.co.in>, \"MUKESH KUMAR\" <mukesh.kumar@eil.co.in>, \"anand yadav\" <anand.yadav@eil.co.in>, \"SANJIT KUMAR KESHRI\" <sanjit.keshri@eil.co.in>, \"PINTU LAL\" <pintu.lal@eil.co.in>, \"SUSHANT CHANDRA SAXENA\" <sushant.saxena@eil.co.in>, \"VIKAS VIKAS\" <vikask@eil.co.in>, \"PRINCE PRINCE\" <prince.gupta@eil.co.in>\n"
"Cc: \"NALIN KUMAR\" <kumar.nalin@eil.co.in>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")