const regex = /[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in', 'gm')
const str = ` "ABHAY KUMAR" <abhay.kumar@eil.co.in>, "JATINDER S DUGGAL" <js.duggal@eil.co.in>, "MAHESH EASWARAN" <mahesh.easwaran@eil.co.in>, "MAHESH GUPTA" <mahesh.gupta@eil.co.in>, "MUKESH KUMAR" <mukesh.kumar@eil.co.in>, "anand yadav" <anand.yadav@eil.co.in>, "SANJIT KUMAR KESHRI" <sanjit.keshri@eil.co.in>, "PINTU LAL" <pintu.lal@eil.co.in>, "SUSHANT CHANDRA SAXENA" <sushant.saxena@eil.co.in>, "VIKAS VIKAS" <vikask@eil.co.in>, "PRINCE PRINCE" <prince.gupta@eil.co.in>
Cc: "NALIN KUMAR" <kumar.nalin@eil.co.in>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}