// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in").unwrap();
let string = " \"ABHAY KUMAR\" <abhay.kumar@eil.co.in>, \"JATINDER S DUGGAL\" <js.duggal@eil.co.in>, \"MAHESH EASWARAN\" <mahesh.easwaran@eil.co.in>, \"MAHESH GUPTA\" <mahesh.gupta@eil.co.in>, \"MUKESH KUMAR\" <mukesh.kumar@eil.co.in>, \"anand yadav\" <anand.yadav@eil.co.in>, \"SANJIT KUMAR KESHRI\" <sanjit.keshri@eil.co.in>, \"PINTU LAL\" <pintu.lal@eil.co.in>, \"SUSHANT CHANDRA SAXENA\" <sushant.saxena@eil.co.in>, \"VIKAS VIKAS\" <vikask@eil.co.in>, \"PRINCE PRINCE\" <prince.gupta@eil.co.in>
Cc: \"NALIN KUMAR\" <kumar.nalin@eil.co.in>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}