use strict;
my $str = 'bind_password = \'grafana\'';
my $regex = qr/(bind_password = ')grafana'/mp;
my $subst = '$1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";