#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\<span\sclass\=\"js_value\stab-weather__value_l\"\>\s*+([+-]\d++)\s*+\<span\sclass\=\"tab-weather__value_m\"\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}"
Local $sString = "<span class="js_value tab-weather__value_l">" & @CRLF & _
" +6<span class="tab-weather__value_m">,2</span></span>" & @CRLF & _
"<span class="js_value tab-weather__value_l">" & @CRLF & _
" -12<span class="tab-weather__value_m">.45</span></span>" & @CRLF & _
"<span class="js_value tab-weather__value_l">" & @CRLF & _
" +0<span class="tab-weather__value_m">,1</span></span>"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)