using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<span\sclass\=\""js_value\stab-weather__value_l\""\>\s*+([+-]\d++)\s*+\<span\sclass\=\""tab-weather__value_m\""\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}";
string substitution = @"$1$2";
string input = @"<span class=""js_value tab-weather__value_l"">
+6<span class=""tab-weather__value_m"">,2</span></span>
<span class=""js_value tab-weather__value_l"">
-12<span class=""tab-weather__value_m"">.45</span></span>
<span class=""js_value tab-weather__value_l"">
+0<span class=""tab-weather__value_m"">,1</span></span>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}