use strict;
my $str = '<span class="js_value tab-weather__value_l">
+6<span class="tab-weather__value_m">,2</span></span>
<span class="js_value tab-weather__value_l">
-12<span class="tab-weather__value_m">.45</span></span>
<span class="js_value tab-weather__value_l">
+0<span class="tab-weather__value_m">,1</span></span>';
my $regex = qr/\<span\sclass\=\"js_value\stab-weather__value_l\"\>\s*+([+-]\d++)\s*+\<span\sclass\=\"tab-weather__value_m\"\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";