package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<span\sclass\=\"js_value\stab-weather__value_l\"\>\s*+([+-]\d++)\s*+\<span\sclass\=\"tab-weather__value_m\"\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}`)
var str = `<span class="js_value tab-weather__value_l">
+6<span class="tab-weather__value_m">,2</span></span>
<span class="js_value tab-weather__value_l">
-12<span class="tab-weather__value_m">.45</span></span>
<span class="js_value tab-weather__value_l">
+0<span class="tab-weather__value_m">,1</span></span>`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}