// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\<span\sclass\=\"js_value\stab-weather__value_l\"\>\s*+([+-]\d++)\s*+\<span\sclass\=\"tab-weather__value_m\"\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}"#).unwrap();
let string = "<span class=\"js_value tab-weather__value_l\">
+6<span class=\"tab-weather__value_m\">,2</span></span>
<span class=\"js_value tab-weather__value_l\">
-12<span class=\"tab-weather__value_m\">.45</span></span>
<span class=\"js_value tab-weather__value_l\">
+0<span class=\"tab-weather__value_m\">,1</span></span>";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}