re = /\<span\sclass\=\"js_value\stab-weather__value_l\"\>\s*+([+-]\d++)\s*+\<span\sclass\=\"tab-weather__value_m\"\>\s*+([.,]\d++)(?:\s*+\<\/span\>){2}/m
str = '<span class="js_value tab-weather__value_l">
+6<span class="tab-weather__value_m">,2</span></span>
<span class="js_value tab-weather__value_l">
-12<span class="tab-weather__value_m">.45</span></span>
<span class="js_value tab-weather__value_l">
+0<span class="tab-weather__value_m">,1</span></span>'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result