import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<span\\sclass\\=\\\"js_value\\stab-weather__value_l\\\"\\>\\s*+([+-]\\d++)\\s*+\\<span\\sclass\\=\\\"tab-weather__value_m\\\"\\>\\s*+([.,]\\d++)(?:\\s*+\\<\\/span\\>){2}";
final String string = "<span class=\"js_value tab-weather__value_l\">\n"
+ " +6<span class=\"tab-weather__value_m\">,2</span></span>\n"
+ "<span class=\"js_value tab-weather__value_l\">\n"
+ " -12<span class=\"tab-weather__value_m\">.45</span></span>\n"
+ "<span class=\"js_value tab-weather__value_l\">\n"
+ " +0<span class=\"tab-weather__value_m\">,1</span></span>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}